Never forget plugin.xml

I’ve spent half day trying to figure out what was happening with a the new Warpath Classpath Container plugin for Candy for Appfuse. It worked like a charm when launched inside the PDE, but when installed on a clean Eclipse install, it just won’t work.

I won’t tell you all the things I’ve done to try to narrow the source of the problem. All you need to know is that you really, really, really need to include plugin.xml in the binary build of your plug-in.

I think it is checked by default, but I seem to have removed the tick.



%d bloggers like this: